aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-03-05 16:23:07 -0800
committerAaron Rossetto <aaron.rossetto@ni.com>2020-04-02 12:36:20 -0500
commit1383fde3457168ed759d6ed3b913dfae8a6085ef (patch)
tree60acf5dfd0a917e6fcc562005dd2405332e1f8bb /host/CMakeLists.txt
parentc65166562f1278f6633b183b7188789158210544 (diff)
downloaduhd-1383fde3457168ed759d6ed3b913dfae8a6085ef.tar.gz
uhd-1383fde3457168ed759d6ed3b913dfae8a6085ef.tar.bz2
uhd-1383fde3457168ed759d6ed3b913dfae8a6085ef.zip
uhd: paths: Harmonize around XDG Base Directory specification
Up until now, we completely ignore the XDG specification. This commit does the following to change that: - It uses XDG_DATA_HOME and XDG_CONFIG_HOME for cal and config data, respectively. - If config data is in ~/.uhd/uhd.conf, that is still accepted, but if it conflicts with $XDG_CONFIG_HOME/uhd.conf, it is ignored and a warning is displayed - The default location for cal data is thus ${HOME}/.local/share/uhd/cal on Unix, and %LOCALAPPDATA%\uhd\cal on Windows. This is a change in location! - The UHD_CONFIG_DIR environment variable was confusingly named and is now removed. It provided an alternative location than the home directory. The same purpose is now much better served by XDG_DATA_HOME and XDG_CONFIG_HOME. The specification can be found here: specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 95f110e9e..2d966fd22 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -130,9 +130,9 @@ set(PKG_MAN_DIR share/man/man1)
# UHD config files
########################################################################
set(UHD_USER_CONF_FILE
- ".uhd/uhd.conf"
+ "uhd.conf"
CACHE STRING
- "Location of the user-specific UHD configuration file, relative to APPDATA (or HOME)"
+ "Location of the user-specific UHD configuration file, relative to APPDATA (or XDG_CONFIG_HOME)"
)
if(UNIX)
set(UHD_SYS_CONF_FILE