aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2016-02-08 11:00:05 -0800
committerMartin Braun <martin.braun@ettus.com>2016-02-08 11:00:05 -0800
commite9bd85c60b5de5f2979d8bf2886d3931aa03f1c8 (patch)
treeb56a5fa74ab5fdf9785e2a63d5b320a9e7b389cd /host/CMakeLists.txt
parent502d952a085c7940945f7ec406db3a46df5c8311 (diff)
parent97d338d2f8adabab13992578ece4d4b6b5d6a530 (diff)
downloaduhd-e9bd85c60b5de5f2979d8bf2886d3931aa03f1c8.tar.gz
uhd-e9bd85c60b5de5f2979d8bf2886d3931aa03f1c8.tar.bz2
uhd-e9bd85c60b5de5f2979d8bf2886d3931aa03f1c8.zip
Merge branch 'maint'
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index f7a35fc8b..d3ae2b71c 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright 2010-2015 Ettus Research LLC
+# Copyright 2010-2016 Ettus Research LLC
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -162,6 +162,7 @@ IF(MSVC)
-D_CRT_SECURE_NO_DEPRECATE
-D_CRT_NONSTDC_NO_WARNINGS
-D_CRT_NONSTDC_NO_DEPRECATE
+ -D_WINSOCK_DEPRECATED_NO_WARNINGS
)
ADD_DEFINITIONS(/MP) #multi-threaded build
ADD_DEFINITIONS(/bigobj) #Increases the number of addressable sections in an .obj file.
@@ -187,10 +188,14 @@ SET(BOOST_REQUIRED_COMPONENTS
program_options
regex
system
- thread
unit_test_framework
serialization
)
+IF(MINGW)
+ LIST(APPEND BOOST_REQUIRED_COMPONENTS thread_win32)
+ELSE()
+ LIST(APPEND BOOST_REQUIRED_COMPONENTS thread)
+ENDIF()
IF(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
LIST(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix