aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2016-08-12 14:18:26 -0700
committerMartin Braun <martin.braun@ettus.com>2016-08-12 14:18:26 -0700
commit4f18efa3d1925e8c37890d23ec627aee684ecc96 (patch)
tree6815d515305d888539a108fcb43ae6e2427c0c13 /host/CMakeLists.txt
parent19db62f4f4adef0832b62673ae257cb8fefb7d0b (diff)
downloaduhd-4f18efa3d1925e8c37890d23ec627aee684ecc96.tar.gz
uhd-4f18efa3d1925e8c37890d23ec627aee684ecc96.tar.bz2
uhd-4f18efa3d1925e8c37890d23ec627aee684ecc96.zip
cmake: Fixed some bugs related to identifying git branch
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index ccea35006..c388a2ada 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -489,7 +489,7 @@ ELSEIF(UHDHOST_PKG)
SET(PRINT_APPEND " (Debian uhd-host package configuration)")
ENDIF(LIBUHD_PKG)
UHD_PRINT_COMPONENT_SUMMARY()
-IF(UHD_VERSION_DEVEL)
+IF(UHD_VERSION_DEVEL AND NOT UHD_GIT_BRANCH STREQUAL "maint")
MESSAGE(STATUS "******************************************************")
IF(UHD_GIT_BRANCH STREQUAL "master")
MESSAGE(STATUS "* You are building the UHD development master branch.")
@@ -502,6 +502,6 @@ IF(UHD_VERSION_DEVEL)
MESSAGE(STATUS "* unstable and/or experimental!")
ENDIF(UHD_GIT_BRANCH STREQUAL "master")
MESSAGE(STATUS "******************************************************")
-ENDIF(UHD_VERSION_DEVEL)
+ENDIF(UHD_VERSION_DEVEL AND NOT UHD_GIT_BRANCH STREQUAL "maint")
MESSAGE(STATUS "Building version: ${UHD_VERSION}${PRINT_APPEND}")
MESSAGE(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")