aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Maitland Bottoms <bottoms@debian.org>2018-11-01 07:50:07 -0700
committerMartin Braun <martin.braun@ettus.com>2018-11-15 16:40:56 -0800
commit1f0c8bd2c76a3d9149fd72a8b1a9a8356362018e (patch)
tree2fd979f165db4b8d35c8783bbd669dfe5b720d75 /host/CMakeLists.txt
parent3e7decabe166613710dae8e6f1d6512a6f6aa6bc (diff)
downloaduhd-1f0c8bd2c76a3d9149fd72a8b1a9a8356362018e.tar.gz
uhd-1f0c8bd2c76a3d9149fd72a8b1a9a8356362018e.tar.bz2
uhd-1f0c8bd2c76a3d9149fd72a8b1a9a8356362018e.zip
cmake: Improve logic for UHD_IMAGES_DIR
A CMake option is either On or Off. UHD_IMAGES_DIR gets a sane default if not specified on the CMake command line.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 5c8b5054b..cfbc81d34 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -167,9 +167,7 @@ if(NOT DEFINED UHD_IMAGES_DIR)
endif(DEFINED FPGA_IMAGES_DIR)
endif(NOT DEFINED UHD_IMAGES_DIR)
-option(UHD_IMAGES_DIR "Path to installed UHD image binaries.")
message( STATUS "Using UHD Images Directory: ${UHD_IMAGES_DIR}" )
-add_definitions(-DUHD_IMAGES_DIR=${UHD_IMAGES_DIR})
if(DEFINED UHD_IMAGES_DIR_WINREG_KEY)
add_definitions(-DUHD_IMAGES_DIR_WINREG_KEY=${UHD_IMAGES_DIR_WINREG_KEY})