summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-05-18 17:46:34 -0700
committerJosh Blum <josh@joshknows.com>2010-05-18 17:46:34 -0700
commit21e9cf4bece884ced5b7294e012be971e941c511 (patch)
tree634f4b8b27d9dc8a6ebfc2ab731bddf62d0bbe22 /host/CMakeLists.txt
parent7c98884eda041b676584059ca3a63b11f1bbd505 (diff)
parent4ea8822a50073b01ede9e0b0f7c8c713767ea1b8 (diff)
downloaduhd-21e9cf4bece884ced5b7294e012be971e941c511.tar.gz
uhd-21e9cf4bece884ced5b7294e012be971e941c511.tar.bz2
uhd-21e9cf4bece884ced5b7294e012be971e941c511.zip
Merge branch 'work'
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index f2725e4b3..0b2d3f012 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -62,6 +62,7 @@ IF(UNIX)
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-ansi HAVE_ANSI)
#only export symbols that are declared to be part of the uhd api:
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)
+ UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-O3 HAVE_O3) #have some optimizations
ENDIF(UNIX)
IF(WIN32)