summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-04-18 00:37:24 -0700
committerJosh Blum <josh@joshknows.com>2010-04-18 00:37:24 -0700
commit77c578fc639bb3d54c6730402de04a22636b1d6d (patch)
treeb20154e5337ff498c831a2472f834bb3087f85e9 /host/CMakeLists.txt
parent1ee33acace699a5374d605c71dbe4075b85aecc9 (diff)
downloaduhd-77c578fc639bb3d54c6730402de04a22636b1d6d.tar.gz
uhd-77c578fc639bb3d54c6730402de04a22636b1d6d.tar.bz2
uhd-77c578fc639bb3d54c6730402de04a22636b1d6d.zip
Created a docs directory to house restructured text documentation.
Moved doxygen build rules into the docs build directory. Created rst docs for building and burning usrp2.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt21
1 files changed, 3 insertions, 18 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 6334b44ff..4ef6278b9 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -124,24 +124,8 @@ INSTALL(
)
########################################################################
-# Setup Docs
-########################################################################
-INCLUDE(FindDoxygen)
-
-IF(DOXYGEN_FOUND)
- SET(CMAKE_CURRENT_BINARY_DIR_DOXYGEN ${CMAKE_CURRENT_BINARY_DIR}/doxygen)
- CONFIGURE_FILE(
- ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
- ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
- @ONLY)
- ADD_CUSTOM_COMMAND(OUTPUT ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN}
- COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
- COMMENT "Generating documentation with doxygen"
- )
- ADD_CUSTOM_TARGET(docs ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN})
- INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN} DESTINATION ${PKG_DOC_DIR})
-ENDIF(DOXYGEN_FOUND)
-
+# Install Package Docs
+########################################################################
INSTALL(FILES
${CMAKE_CURRENT_SOURCE_DIR}/README
${CMAKE_CURRENT_SOURCE_DIR}/LICENSE
@@ -152,6 +136,7 @@ INSTALL(FILES
########################################################################
# Add the subdirectories
########################################################################
+ADD_SUBDIRECTORY(docs)
ADD_SUBDIRECTORY(examples)
ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(lib)