summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-05-17 22:24:14 -0700
committerJosh Blum <josh@joshknows.com>2010-05-17 22:24:14 -0700
commit18f3f257145c4dcd981182221779550a7474488a (patch)
treee038011b289d65fbc23e2f07853d74a5dc6690e9 /host/CMakeLists.txt
parent101afd526de722b6d30381340a7ca8148aa9a6d7 (diff)
downloaduhd-18f3f257145c4dcd981182221779550a7474488a.tar.gz
uhd-18f3f257145c4dcd981182221779550a7474488a.tar.bz2
uhd-18f3f257145c4dcd981182221779550a7474488a.zip
Created config macro to force inline.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index f2725e4b3..0b2d3f012 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -62,6 +62,7 @@ IF(UNIX)
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-ansi HAVE_ANSI)
#only export symbols that are declared to be part of the uhd api:
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)
+ UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-O3 HAVE_O3) #have some optimizations
ENDIF(UNIX)
IF(WIN32)