aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/x300/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Hilburn <ben.hilburn@ettus.com>2014-02-04 11:04:07 -0800
committerBen Hilburn <ben.hilburn@ettus.com>2014-02-04 11:04:07 -0800
commit178ac3f1c9950d383c8f64b3df464c0f943c4a23 (patch)
tree318ed621a7b59b7d34d4ce6e4a92f73f0bcef509 /firmware/x300/lib/CMakeLists.txt
parent2718ac110fa931cc29daf7cb3dc5ab6230ee02ab (diff)
downloaduhd-178ac3f1c9950d383c8f64b3df464c0f943c4a23.tar.gz
uhd-178ac3f1c9950d383c8f64b3df464c0f943c4a23.tar.bz2
uhd-178ac3f1c9950d383c8f64b3df464c0f943c4a23.zip
Merging USRP X300 and X310 support!!
Diffstat (limited to 'firmware/x300/lib/CMakeLists.txt')
-rw-r--r--firmware/x300/lib/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/firmware/x300/lib/CMakeLists.txt b/firmware/x300/lib/CMakeLists.txt
new file mode 100644
index 000000000..ed5a0a7c0
--- /dev/null
+++ b/firmware/x300/lib/CMakeLists.txt
@@ -0,0 +1,32 @@
+#
+# Copyright 2010-2013 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+
+add_library(usrpfw STATIC
+ udp_uart.c
+ wb_uart.c
+ wb_i2c.c
+ printf.c
+ wb_pkt_iface64.c
+ u3_net_stack.c
+ ethernet.c
+ mdelay.c
+ chinch.c
+ print_addrs.c
+ link_state_route_proto.c
+)