summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/usrp2p/Makefile.am
diff options
context:
space:
mode:
authorNick Foster <nick@nerdnetworks.org>2010-10-12 14:46:41 -0700
committerNick Foster <nick@nerdnetworks.org>2010-10-12 14:46:41 -0700
commit5982ec4ee2c6f9efca1c5068e42dc38b822df7dc (patch)
tree6b15ce5f837ea57cc5c9fdf79e45fdbd2f44d9de /firmware/microblaze/usrp2p/Makefile.am
parent3df994e1c784d7037e869610f1417fe64e0e89a8 (diff)
downloaduhd-5982ec4ee2c6f9efca1c5068e42dc38b822df7dc.tar.gz
uhd-5982ec4ee2c6f9efca1c5068e42dc38b822df7dc.tar.bz2
uhd-5982ec4ee2c6f9efca1c5068e42dc38b822df7dc.zip
USRP2P: This is surprisingly involved. Adding a consistent interface to deal with hardware revisions.
Diffstat (limited to 'firmware/microblaze/usrp2p/Makefile.am')
-rw-r--r--firmware/microblaze/usrp2p/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/firmware/microblaze/usrp2p/Makefile.am b/firmware/microblaze/usrp2p/Makefile.am
index 0d0b60437..a5df3ff08 100644
--- a/firmware/microblaze/usrp2p/Makefile.am
+++ b/firmware/microblaze/usrp2p/Makefile.am
@@ -22,10 +22,11 @@ AM_CFLAGS = \
AM_LDFLAGS = \
$(COMMON_LFLAGS) \
- libusrp2p.a \
-Wl,-defsym -Wl,_TEXT_START_ADDR=0x8050 \
-Wl,-defsym -Wl,_STACK_SIZE=3072
+LDADD = libusrp2p.a
+
#all of this here is to relocate the hardware vectors to somewhere normal.
RELOCATE_ARGS = \
--change-section-address .vectors.sw_exception+0x8000 \