summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/usrp2p/Makefile.am
diff options
context:
space:
mode:
authorNick Foster <nick@nerdnetworks.org>2010-08-17 18:35:11 -0700
committerNick Foster <nick@nerdnetworks.org>2010-08-17 18:35:11 -0700
commit9d10efa5f0f81e1a971e92b28ba7f38e0384fdab (patch)
tree7b797016a4da8625dabc41c9bcc9ee0216092507 /firmware/microblaze/usrp2p/Makefile.am
parent40faee2e6d87f7364a0c0c2cf310f1483c0331cf (diff)
downloaduhd-9d10efa5f0f81e1a971e92b28ba7f38e0384fdab.tar.gz
uhd-9d10efa5f0f81e1a971e92b28ba7f38e0384fdab.tar.bz2
uhd-9d10efa5f0f81e1a971e92b28ba7f38e0384fdab.zip
UDP firmware update support for USRP2P.
The hooks are in there for USRP2, but without CPLD changes it won't support it. Added an app host/utils/usrp2p_fw_update.py to write to USRP2P over the wire. Lots of TODOs in that file. Caveat -- fw_common.h, bootloader_utils.h, and the .py app MUST ALL AGREE!
Diffstat (limited to 'firmware/microblaze/usrp2p/Makefile.am')
-rw-r--r--firmware/microblaze/usrp2p/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/firmware/microblaze/usrp2p/Makefile.am b/firmware/microblaze/usrp2p/Makefile.am
index ddc7006ca..c9ed3b99b 100644
--- a/firmware/microblaze/usrp2p/Makefile.am
+++ b/firmware/microblaze/usrp2p/Makefile.am
@@ -32,6 +32,7 @@ COMMON_IHX_ARGS = \
--change-section-address .vectors.hw_exception+0x8000 \
--change-section-address .vectors.interrupt+0x8000 \
--change-section-address .vectors.reset+0x8000
+
# $(MB_OBJCOPY) -O ihex $< $@
# the below would work if objcopy weren't written by apes
# $(MB_OBJCOPY) -O ihex -w --change-section-address .vectors*+0x8000 $< $@
@@ -49,7 +50,8 @@ libusrp2p_a_SOURCES = \
spi_flash.c \
spi_flash_read.c \
bootloader_utils.c \
- ethernet.c
+ ethernet.c \
+ udp_fw_update.c
noinst_PROGRAMS = \
usrp2p_txrx_uhd.elf \