summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/lwip/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-10 16:53:37 -0800
committerJosh Blum <josh@joshknows.com>2010-02-10 16:53:37 -0800
commit2b6c895b4f9916a06b14c40f545c9b4e53141c9a (patch)
treefee48a8e129bf36e67a6ba1b6d7898429e79b0bb /firmware/microblaze/lwip/Makefile.am
parenta61cc56bb6d544742487326ccba7c457bbddb0e6 (diff)
downloaduhd-2b6c895b4f9916a06b14c40f545c9b4e53141c9a.tar.gz
uhd-2b6c895b4f9916a06b14c40f545c9b4e53141c9a.tar.bz2
uhd-2b6c895b4f9916a06b14c40f545c9b4e53141c9a.zip
net_common working in this state with control udp packets
Diffstat (limited to 'firmware/microblaze/lwip/Makefile.am')
-rw-r--r--firmware/microblaze/lwip/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/firmware/microblaze/lwip/Makefile.am b/firmware/microblaze/lwip/Makefile.am
new file mode 100644
index 000000000..cb0a0446e
--- /dev/null
+++ b/firmware/microblaze/lwip/Makefile.am
@@ -0,0 +1,37 @@
+#
+# Copyright 2009 Free Software Foundation, Inc.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+noinst_LIBRARIES = \
+ liblwip.a
+
+liblwip_a_SOURCES = \
+ $(LWIPDIR)/src/api/err.c \
+ $(LWIPDIR)/src/core/init.c \
+ $(LWIPDIR)/src/core/mem.c \
+ $(LWIPDIR)/src/core/memp.c \
+ $(LWIPDIR)/src/core/netif.c \
+ $(LWIPDIR)/src/core/pbuf.c \
+ $(LWIPDIR)/src/core/stats.c \
+ $(LWIPDIR)/src/core/udp.c \
+ $(LWIPDIR)/src/core/ipv4/icmp.c \
+ $(LWIPDIR)/src/core/ipv4/inet.c \
+ $(LWIPDIR)/src/core/ipv4/ip.c \
+ $(LWIPDIR)/src/core/ipv4/ip_addr.c \
+ $(LWIPDIR)/src/core/ipv4/ip_frag.c \
+ $(LWIPDIR)/src/netif/etharp.c