summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/configure.ac
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-10 11:57:58 -0800
committerJosh Blum <josh@joshknows.com>2010-02-10 11:57:58 -0800
commitd088a11bf7c257ba45bf0c37a41e5038b302bc44 (patch)
tree8bbb4d90285a181c603c117de4504e73066afe48 /firmware/microblaze/configure.ac
parente2044e13ec4ad94e9739402257134abd92cf1521 (diff)
downloaduhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.tar.gz
uhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.tar.bz2
uhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.zip
Copied a snapshot of the usrp2 firmware into the microblaze firmware directory in the uhd repo.
Added erllc copyrights to the files created and modified at erllc.
Diffstat (limited to 'firmware/microblaze/configure.ac')
-rw-r--r--firmware/microblaze/configure.ac46
1 files changed, 46 insertions, 0 deletions
diff --git a/firmware/microblaze/configure.ac b/firmware/microblaze/configure.ac
new file mode 100644
index 000000000..4c96d607e
--- /dev/null
+++ b/firmware/microblaze/configure.ac
@@ -0,0 +1,46 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+##################################################
+## Setup Autotools
+##################################################
+AC_PREREQ(2.60)
+AC_INIT
+AM_INIT_AUTOMAKE(uhd-mb, 0)
+
+##################################################
+## Setup Compiler
+##################################################
+dnl Fix 2.64 cross compile detection for AVR and RTEMS
+dnl by not trying to compile fopen.
+m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.64],
+ [m4_foreach([_GCC_LANG], [C, C++, Fortran, Fortran 77],
+ [m4_define([_AC_LANG_IO_PROGRAM(]_GCC_LANG[)], m4_defn([AC_LANG_PROGRAM(]_GCC_LANG[)]))])])
+
+AC_PROG_CC([mb-gcc])
+LT_INIT
+
+##################################################
+## Create Files
+##################################################
+AC_CONFIG_FILES([ \
+ Makefile \
+ apps/Makefile \
+ include/Makefile \
+ lib/Makefile \
+])
+AC_OUTPUT