summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/apps/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-10 11:57:58 -0800
committerJosh Blum <josh@joshknows.com>2010-02-10 11:57:58 -0800
commitd088a11bf7c257ba45bf0c37a41e5038b302bc44 (patch)
tree8bbb4d90285a181c603c117de4504e73066afe48 /firmware/microblaze/apps/Makefile.am
parente2044e13ec4ad94e9739402257134abd92cf1521 (diff)
downloaduhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.tar.gz
uhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.tar.bz2
uhd-d088a11bf7c257ba45bf0c37a41e5038b302bc44.zip
Copied a snapshot of the usrp2 firmware into the microblaze firmware directory in the uhd repo.
Added erllc copyrights to the files created and modified at erllc.
Diffstat (limited to 'firmware/microblaze/apps/Makefile.am')
-rw-r--r--firmware/microblaze/apps/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/firmware/microblaze/apps/Makefile.am b/firmware/microblaze/apps/Makefile.am
new file mode 100644
index 000000000..91e83b90a
--- /dev/null
+++ b/firmware/microblaze/apps/Makefile.am
@@ -0,0 +1,76 @@
+#
+# Copyright 2007,2008 Free Software Foundation, Inc.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+LDADD = ../lib/libu2fw.a
+
+noinst_PROGRAMS = \
+ blink_leds \
+ blink_leds2 \
+ buf_ram_test \
+ burn_dbsrx_eeprom \
+ can_i_sub \
+ echo \
+ hello \
+ read_dbids \
+ set_hw_rev \
+ test1 \
+ test_db_spi \
+ test_i2c \
+ test_sd \
+ test_ram \
+ test_phy_comm \
+ test_lsadc \
+ test_lsdac \
+ timer_test \
+ txrx \
+ burnrev30 \
+ burnrev31 \
+ burnrev40 \
+ sd_gentest \
+ sd_bounce
+
+#nononono = \
+# eth_serdes \
+# gen_eth_packets \
+# rcv_eth_packets \
+# tx_standalone \
+# factory_test \
+# serdes_txrx \
+# mimo_tx \
+# mimo_tx_slave \
+# ibs_rx_test \
+# ibs_tx_test
+
+# tx_drop_SOURCES = tx_drop.c app_common.c
+# tx_drop_rate_limited_SOURCES = tx_drop_rate_limited.c app_common.c
+# tx_drop2_SOURCES = tx_drop2.c app_common.c
+txrx_SOURCES = txrx.c app_common_v2.c
+factory_test_SOURCES = factory_test.c app_common_v2.c
+eth_serdes_SOURCES = eth_serdes.c app_passthru_v2.c
+serdes_txrx_SOURCES = serdes_txrx.c app_common_v2.c
+mimo_tx_SOURCES = mimo_tx.c mimo_app_common_v2.c
+mimo_tx_slave_SOURCES = mimo_tx_slave.c app_common_v2.c
+
+noinst_HEADERS = \
+ app_common_v2.h \
+ app_passthru_v2.h \
+ mimo_app_common_v2.h
+
+
+MOSTLYCLEANFILES = *.map