summaryrefslogtreecommitdiffstats
path: root/firmware/fx2/include/Makefile.am
diff options
context:
space:
mode:
authorNick Foster <nick@nerdnetworks.org>2010-09-15 14:58:44 -0700
committerNick Foster <nick@nerdnetworks.org>2010-09-15 14:58:44 -0700
commited245848df8cc011ae8fe30833ecc28049139db5 (patch)
treeda03d37de541826df734e8ab87e0b6114595afc8 /firmware/fx2/include/Makefile.am
parent44ac4461407aae3e26b218a1ab1bd27f893c5e96 (diff)
parent72646d1960b0c979afec225e741d7d89a827c7d0 (diff)
downloaduhd-ed245848df8cc011ae8fe30833ecc28049139db5.tar.gz
uhd-ed245848df8cc011ae8fe30833ecc28049139db5.tar.bz2
uhd-ed245848df8cc011ae8fe30833ecc28049139db5.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into usrp2p
Conflicts: host/lib/usrp/usrp2/CMakeLists.txt host/lib/usrp/usrp2/mboard_impl.cpp host/lib/usrp/usrp2/usrp2_regs.hpp
Diffstat (limited to 'firmware/fx2/include/Makefile.am')
-rw-r--r--firmware/fx2/include/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/firmware/fx2/include/Makefile.am b/firmware/fx2/include/Makefile.am
new file mode 100644
index 000000000..e17726c07
--- /dev/null
+++ b/firmware/fx2/include/Makefile.am
@@ -0,0 +1,61 @@
+#
+# Copyright 2003 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+usrpincludedir = $(includedir)/usrp
+
+usrpinclude_HEADERS = \
+ usrp_i2c_addr.h \
+ usrp_spi_defs.h \
+ fpga_regs_common.h \
+ fpga_regs_standard.h
+
+
+noinst_HEADERS = \
+ delay.h \
+ fpga_regs_common.v \
+ fpga_regs_standard.v \
+ fpga_regs0.h \
+ fx2regs.h \
+ fx2utils.h \
+ i2c.h \
+ isr.h \
+ syncdelay.h \
+ timer.h \
+ usb_common.h \
+ usb_descriptors.h \
+ usb_requests.h \
+ usrp_commands.h \
+ usrp_config.h \
+ usrp_ids.h \
+ usrp_interfaces.h
+
+
+CODE_GENERATOR = \
+ generate_regs.py
+
+EXTRA_DIST = \
+ $(CODE_GENERATOR)
+
+fpga_regs_common.v: fpga_regs_common.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(PYTHON) $(srcdir)/generate_regs.py $(srcdir)/fpga_regs_common.h $@
+
+fpga_regs_standard.v: fpga_regs_standard.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(PYTHON) $(srcdir)/generate_regs.py $(srcdir)/fpga_regs_standard.h $@