summaryrefslogtreecommitdiffstats
path: root/firmware/fx2/include/Makefile.am
diff options
context:
space:
mode:
authorThomas Tsou <ttsou@vt.edu>2010-08-05 11:48:41 -0700
committerThomas Tsou <ttsou@vt.edu>2010-08-13 12:25:36 -0700
commit70eae1d242a9530cab4efa927bd1331b099fdd00 (patch)
treea0050754ec06f71e9b2dd4415e576c370143b429 /firmware/fx2/include/Makefile.am
parentef6953024f1075a729e85f2511c75de337879888 (diff)
downloaduhd-70eae1d242a9530cab4efa927bd1331b099fdd00.tar.gz
uhd-70eae1d242a9530cab4efa927bd1331b099fdd00.tar.bz2
uhd-70eae1d242a9530cab4efa927bd1331b099fdd00.zip
usrp1: Add FX2 firmware files
These firmware files for the usrp1 are imported from GNURadio.
Diffstat (limited to 'firmware/fx2/include/Makefile.am')
-rw-r--r--firmware/fx2/include/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/firmware/fx2/include/Makefile.am b/firmware/fx2/include/Makefile.am
new file mode 100644
index 000000000..e17726c07
--- /dev/null
+++ b/firmware/fx2/include/Makefile.am
@@ -0,0 +1,61 @@
+#
+# Copyright 2003 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+usrpincludedir = $(includedir)/usrp
+
+usrpinclude_HEADERS = \
+ usrp_i2c_addr.h \
+ usrp_spi_defs.h \
+ fpga_regs_common.h \
+ fpga_regs_standard.h
+
+
+noinst_HEADERS = \
+ delay.h \
+ fpga_regs_common.v \
+ fpga_regs_standard.v \
+ fpga_regs0.h \
+ fx2regs.h \
+ fx2utils.h \
+ i2c.h \
+ isr.h \
+ syncdelay.h \
+ timer.h \
+ usb_common.h \
+ usb_descriptors.h \
+ usb_requests.h \
+ usrp_commands.h \
+ usrp_config.h \
+ usrp_ids.h \
+ usrp_interfaces.h
+
+
+CODE_GENERATOR = \
+ generate_regs.py
+
+EXTRA_DIST = \
+ $(CODE_GENERATOR)
+
+fpga_regs_common.v: fpga_regs_common.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(PYTHON) $(srcdir)/generate_regs.py $(srcdir)/fpga_regs_common.h $@
+
+fpga_regs_standard.v: fpga_regs_standard.h generate_regs.py
+ PYTHONPATH=$(top_srcdir)/usrp/firmware/include $(PYTHON) $(srcdir)/generate_regs.py $(srcdir)/fpga_regs_standard.h $@