summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-07 16:46:00 -0800
committerJosh Blum <josh@joshknows.com>2010-01-07 16:46:00 -0800
commit67a502ec0fb92b14db5eedf2cff36caacbb0efbf (patch)
treea35ea5a50e43b317d214350892816ed53e373a91 /configure.ac
downloaduhd-67a502ec0fb92b14db5eedf2cff36caacbb0efbf.tar.gz
uhd-67a502ec0fb92b14db5eedf2cff36caacbb0efbf.tar.bz2
uhd-67a502ec0fb92b14db5eedf2cff36caacbb0efbf.zip
skeleton autotools system for uhd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 000000000..e3a766c2b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+
+##################################################
+## Setup Autotools
+##################################################
+AC_PREREQ(2.60)
+AC_INIT
+AM_INIT_AUTOMAKE(usrp_uhd, 0)
+
+##################################################
+## Check Libs
+##################################################
+AC_PROG_CXX
+LT_INIT
+AX_BOOST_BASE([1.36])
+AX_BOOST_THREAD
+
+##################################################
+## Check Programs
+##################################################
+AC_PATH_PROG(SED, sed)
+AC_PATH_PROG(PYTHON, python)
+
+##################################################
+## Create Files
+##################################################
+AC_CONFIG_FILES([ \
+ usrp-uhd.pc \
+ Makefile \
+])
+AC_OUTPUT