summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-15 17:49:35 -0800
committerJosh Blum <josh@joshknows.com>2010-01-15 17:49:35 -0800
commit379d486ed21aace7f8b37d61f713bdc6088b39e5 (patch)
treee0093e4ad60ea9f87780c03a5883eded755b51c2 /configure.ac
parent92c76e574773e99d1bfb5c3a833217b8644779f4 (diff)
downloaduhd-379d486ed21aace7f8b37d61f713bdc6088b39e5.tar.gz
uhd-379d486ed21aace7f8b37d61f713bdc6088b39e5.tar.bz2
uhd-379d486ed21aace7f8b37d61f713bdc6088b39e5.zip
Integrated cppunit into the build system.
Added new test for the usrp dboard stuff.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acb77f90c..0036488c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,15 +14,20 @@ AM_INIT_AUTOMAKE(usrp_uhd, 0)
##################################################
AC_PROG_CXX
LT_INIT
+
AX_BOOST_BASE([1.36], [], AC_MSG_ERROR("cannot find boost"))
AX_BOOST_THREAD
+AM_PATH_CPPUNIT([1.9.6], [HAVE_CPPUNIT=true], [HAVE_CPPUNIT=false])
+AM_CONDITIONAL([HAVE_CPPUNIT], [$HAVE_CPPUNIT])
+
##################################################
## Check Headers
##################################################
AC_DEFUN([UHD_CHECK_HEADER],[
AC_CHECK_HEADER([$1], [], AC_MSG_ERROR("cannot find header $1"))
])
+
UHD_CHECK_HEADER([sys/uio.h])
UHD_CHECK_HEADER([arpa/inet.h])
UHD_CHECK_HEADER([netinet/ether.h])
@@ -33,6 +38,7 @@ UHD_CHECK_HEADER([netinet/ether.h])
AC_DEFUN([UHD_OPTIONAL_CXXFLAG],[
AX_CXX_CHECK_FLAG([$1], [], [], [CXXFLAGS="${CXXFLAGS} $1"])
])
+
UHD_OPTIONAL_CXXFLAG([-Wall])
UHD_OPTIONAL_CXXFLAG([-Wextra])
UHD_OPTIONAL_CXXFLAG([-Werror])