summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-16 10:41:07 -0800
committerJosh Blum <josh@joshknows.com>2010-02-16 10:41:07 -0800
commit1b70ff306342ca1078e105488811a52c49b446f4 (patch)
tree9489b2d99bd2a630a352b06e4ddba1d660b5af53 /CMakeLists.txt
parent9d1041f8150e047d929aaf7c0461201f043d8b93 (diff)
downloaduhd-1b70ff306342ca1078e105488811a52c49b446f4.tar.gz
uhd-1b70ff306342ca1078e105488811a52c49b446f4.tar.bz2
uhd-1b70ff306342ca1078e105488811a52c49b446f4.zip
added uninstall target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 16 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58254e413..3f4559c24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,6 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
PROJECT(UHD)
ENABLE_TESTING()
-#SET(CMAKE_VERBOSE_MAKEFILE true)
########################################################################
# Setup CPack
@@ -71,13 +70,27 @@ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
########################################################################
+# Create Uninstall Target
+########################################################################
+CONFIGURE_FILE(
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+ @ONLY
+)
+
+ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+)
+
+########################################################################
# Create Pkg Config File
########################################################################
CONFIGURE_FILE(
- ${CMAKE_SOURCE_DIR}/uhd.pc.in
- ${CMAKE_CURRENT_BINARY_DIR}/uhd.pc
+ "${CMAKE_SOURCE_DIR}/uhd.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/uhd.pc"
@ONLY
)
+
INSTALL(
FILES ${CMAKE_CURRENT_BINARY_DIR}/uhd.pc
DESTINATION ${LIBRARY_DIR}/pkgconfig