aboutsummaryrefslogtreecommitdiffstats
path: root/sw/demo1/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'sw/demo1/Cargo.toml')
-rw-r--r--sw/demo1/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/sw/demo1/Cargo.toml b/sw/demo1/Cargo.toml
index 7219b30..cf33da1 100644
--- a/sw/demo1/Cargo.toml
+++ b/sw/demo1/Cargo.toml
@@ -6,6 +6,7 @@ edition = "2018"
license = "MIT"
[dependencies]
+arrayvec = { version = "0.5", default-features = false, features = [] }
# alloc-cortex-m = "0.3" # requires nightly
cortex-m = "0.6"
cortex-m-rt = "0.6"
@@ -16,6 +17,9 @@ nb = "0.1"
#stm32h7 = { version = "0.9", features = ["stm32h743", "rt"] }
stm32f1xx-hal = { version = "0.5", features = ["rt", "stm32f103"] }
embedded-hal = { version = "0.2", features = [] }
+shared-bus = { version = "0.1.4", features = ["cortexm"] }
+hd44780-driver = { path = "../deps/hd44780-driver"}
+si5351 = { git = "https://github.com/ilya-epifanov/si5351", rev = "e509c36" }
[profile.dev]
codegen-units = 1