aboutsummaryrefslogtreecommitdiffstats
path: root/sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2020-06-28 16:42:21 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2020-06-28 16:42:21 +0200
commit5d1cff57f9f5acd740a8b5f8c941beefdcc00176 (patch)
treebdfd0e394d6333aead7d3a0295ba3457bd68275d /sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml
parent93220f99a52dc93f9a2d5b11074f60156ef70210 (diff)
downloadpicardy-5d1cff57f9f5acd740a8b5f8c941beefdcc00176.tar.gz
picardy-5d1cff57f9f5acd740a8b5f8c941beefdcc00176.tar.bz2
picardy-5d1cff57f9f5acd740a8b5f8c941beefdcc00176.zip
sw: configure si5351
Diffstat (limited to 'sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml')
-rw-r--r--sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml b/sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml
new file mode 100644
index 0000000..5e51866
--- /dev/null
+++ b/sw/deps/hd44780-driver/examples/stm32f30x/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+edition = "2018"
+name = "stm32f30x-hd44780-example"
+version = "0.1.0"
+license = "MIT"
+publish = false
+
+[dependencies]
+cortex-m = "0.5.8"
+cortex-m-rt = "0.6.5"
+embedded-hal = "0.2.2"
+panic-halt = "0.2.0"
+hd44780-driver = { path = "../.." }
+
+[dependencies.hal]
+version = "0.2.0"
+package = "stm32f30x-hal"
+
+[profile.release]
+codegen-units = 1
+debug = true
+lto = true