aboutsummaryrefslogtreecommitdiffstats
path: root/sw/demo1/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2020-04-10 21:47:17 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2020-04-10 21:47:17 +0200
commitd547c5c5c9834dbb1dbe000b42e09b22f064f947 (patch)
tree13e7c20a839e6ded8267926c27a067e5c0c39d8e /sw/demo1/Cargo.toml
parent3b543dcfac08aeea9891aa7e279db5fe33b9099b (diff)
downloadpicardy-d547c5c5c9834dbb1dbe000b42e09b22f064f947.tar.gz
picardy-d547c5c5c9834dbb1dbe000b42e09b22f064f947.tar.bz2
picardy-d547c5c5c9834dbb1dbe000b42e09b22f064f947.zip
Add demo1 stm32f103 example with blinky code
Diffstat (limited to 'sw/demo1/Cargo.toml')
-rw-r--r--sw/demo1/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/sw/demo1/Cargo.toml b/sw/demo1/Cargo.toml
new file mode 100644
index 0000000..7219b30
--- /dev/null
+++ b/sw/demo1/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "demo1"
+version = "0.1.0"
+authors = ["Matthias P. Braendli <matthias.braendli@mpb.li>"]
+edition = "2018"
+license = "MIT"
+
+[dependencies]
+# alloc-cortex-m = "0.3" # requires nightly
+cortex-m = "0.6"
+cortex-m-rt = "0.6"
+# consider cortex-m-rtfm
+cortex-m-semihosting = "0.3"
+panic-semihosting = "0.5"
+nb = "0.1"
+#stm32h7 = { version = "0.9", features = ["stm32h743", "rt"] }
+stm32f1xx-hal = { version = "0.5", features = ["rt", "stm32f103"] }
+embedded-hal = { version = "0.2", features = [] }
+
+[profile.dev]
+codegen-units = 1
+incremental = false
+
+[profile.release]
+codegen-units = 1
+debug = true
+lto = true