aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2016-05-18 10:09:20 +0300
committerMartin Storsjo <martin@martin.st>2016-05-18 10:13:31 +0300
commit15b128dd826ba86ee962d86b0b06966a25ed9158 (patch)
tree2460a14c40c97ea0d19d7b85ba76582d7f10c4d3 /Makefile.am
parent8fe6faf261313279879f7fbce8798f03aa63ebd5 (diff)
downloadfdk-aac-15b128dd826ba86ee962d86b0b06966a25ed9158.tar.gz
fdk-aac-15b128dd826ba86ee962d86b0b06966a25ed9158.tar.bz2
fdk-aac-15b128dd826ba86ee962d86b0b06966a25ed9158.zip
Explicitly force building in C++98 mode
GCC 6 defaults to C++14 (or more precisely, gnu++14) instead of C++98 (or gnu++98). The fdk-aac source doesn't support being built in this mode at the moment, since it relies on narrowing conversion from unsigned 32 bit integers to FIXP_DBL (which is a signed data type of the same size). The same approach is used upstream in Android as well, since d52f3747683. This fixes buliding with GCC 6.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a90edaa..2c64ca7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/libFDK/include \
-I$(top_srcdir)/libPCMutils/include
-AM_CXXFLAGS = -fno-exceptions -fno-rtti
+AM_CXXFLAGS = -fno-exceptions -fno-rtti -std=c++98
libfdk_aac_la_LINK = $(LINK) $(libfdk_aac_la_LDFLAGS)
# Mention a dummy pure C file to trigger generation of the $(LINK) variable
nodist_EXTRA_libfdk_aac_la_SOURCES = dummy.c