aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2023-10-06 14:01:15 +0300
committerMartin Storsjo <martin@martin.st>2023-10-06 14:49:48 +0300
commit226848a2a10c2b56a4385417a8b2e3fb048fd952 (patch)
treef34a9933a35779bcd471c99f9a92c0fed036a847 /CMakeLists.txt
parent48255d057aa61fde685b20492850043e37d8cb34 (diff)
downloadfdk-aac-226848a2a10c2b56a4385417a8b2e3fb048fd952.tar.gz
fdk-aac-226848a2a10c2b56a4385417a8b2e3fb048fd952.tar.bz2
fdk-aac-226848a2a10c2b56a4385417a8b2e3fb048fd952.zip
cmake: Link the library as C, not C++
This matches how it is done in the autotools build. We try not to rely on the C++ standard library, and this makes sure that this property is maintained (even if developing with CMake).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4db8c7e..8be9d64 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -490,7 +490,8 @@ set_target_properties(fdk-aac PROPERTIES
VERSION 2.0.2
SOVERSION 2
MACHO_COMPATIBILITY_VERSION 3.0.0
- MACHO_CURRENT_VERSION 3.2.0)
+ MACHO_CURRENT_VERSION 3.2.0
+ LINKER_LANGUAGE C)
### Some compiler options from Makefile.am
if(MSVC)