aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-16 18:58:49 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-16 18:58:49 +0200
commit630a51a928741f4c9ca0698ec7513bd83d721c23 (patch)
tree487de48f69429d5099fe1f695930b26aef2e5b1a /Makefile.am
parent4809f3c042a99a639542b1e6cd22657871113260 (diff)
downloadetisnoop-630a51a928741f4c9ca0698ec7513bd83d721c23.tar.gz
etisnoop-630a51a928741f4c9ca0698ec7513bd83d721c23.tar.bz2
etisnoop-630a51a928741f4c9ca0698ec7513bd83d721c23.zip
Remove libfec dependency
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index b4fe70a..311a55f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,13 +47,20 @@ etisnoop_SOURCES = src/dabplussnoop.cpp src/dabplussnoop.hpp \
src/tables.cpp src/tables.hpp \
src/utils.cpp src/utils.hpp \
src/watermarkdecoder.hpp \
- src/wavfile.c src/wavfile.h
+ src/wavfile.c src/wavfile.h \
+ src/fec/char.h \
+ src/fec/decode_rs_char.c src/fec/decode_rs.h \
+ src/fec/encode_rs_char.c src/fec/encode_rs.h \
+ src/fec/fec.h \
+ src/fec/init_rs_char.c src/fec/init_rs.h \
+ src/fec/rs-common.h
bin_PROGRAMS = etisnoop$(EXEEXT)
-EXTRA_DIST = \
- $(top_srcdir)/bootstrap.sh \
- $(top_srcdir)/LICENCE \
- $(top_srcdir)/README.md \
- $(top_srcdir)/remove-duplicate-frames.py
+EXTRA_DIST = $(top_srcdir)/bootstrap.sh \
+ $(top_srcdir)/LICENCE \
+ $(top_srcdir)/README.md \
+ $(top_srcdir)/remove-duplicate-frames.py \
+ $(top_srcdir)/src/fec/LICENSE \
+ $(top_srcdir)/src/fec/README.md