summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc8ce7a..bdc7328 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,10 +52,18 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_INSTALL
+AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
+
# Checks for libraries.
AC_CHECK_LIB([pthread], [pthread_create], [], AC_MSG_ERROR([libpthread is required]))
AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
+# we need to check for libm before checking for fec
+AC_CHECK_LIB([m], [sin])
+AC_SEARCH_LIBS([init_rs_char], [fec], [], [
+ AC_MSG_ERROR([unable to find libfec])
+])
+
# Checks for header files.
AC_MSG_CHECKING([for OS type])
AC_PREPROC_IFELSE(
@@ -188,6 +196,11 @@ AS_IF([test "x$enable_output_zeromq" = "xyes"],
AC_CHECK_LIB(zmq, zmq_init, [true], [AC_MSG_ERROR([ZeroMQ libzmq is required])]))
AS_IF([test "x$enable_output_zeromq" = "xyes"],
AC_DEFINE(HAVE_OUTPUT_ZEROMQ, [1], [Define if ZeroMQ output is enabled]))
+# EDI
+AC_ARG_ENABLE([output_edi],
+ AS_HELP_STRING([--enable-output-edi], [Enable EDI output]))
+AS_IF([test "x$enable_output_edi" = "xyes"],
+ [AC_DEFINE(HAVE_OUTPUT_EDI, [1], [Define if EDI output is enabled])])
# Link against lzmq
AM_CONDITIONAL([HAVE_ZEROMQ_TEST],
@@ -281,7 +294,7 @@ echo
echo "Outputs:"
enabled=""
disabled=""
-for output in file fifo udp tcp raw simul zeromq
+for output in file fifo udp tcp raw simul zeromq edi
do
eval var=\$enable_output_$output
AS_IF([test "x$var" = "xyes"],