summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7d2380..2e420cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,12 @@ AC_PROG_INSTALL
AC_CHECK_LIB([pthread], [pthread_create], [], AC_MSG_ERROR([libpthread is required]))
AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
+# we need to check for libm before checking for fec
+AC_CHECK_LIB([m], [sin])
+AC_SEARCH_LIBS([init_rs_char], [fec], [], [
+ AC_MSG_ERROR([unable to find libfec])
+])
+
# Checks for header files.
AC_MSG_CHECKING([for OS type])
AC_PREPROC_IFELSE(