aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 20 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f06879..80d24e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,8 @@ odr_dabmux_SOURCES =src/DabMux.cpp \
src/input/File.h \
src/input/Udp.cpp \
src/input/Udp.h \
+ src/input/Edi.cpp \
+ src/input/Edi.h \
src/dabOutput/dabOutput.h \
src/dabOutput/dabOutputFile.cpp \
src/dabOutput/dabOutputFifo.cpp \
@@ -98,8 +100,6 @@ odr_dabmux_SOURCES =src/DabMux.cpp \
src/ConfigParser.h \
src/Eti.h \
src/Eti.cpp \
- src/InetAddress.h \
- src/InetAddress.cpp \
src/Interleaver.h \
src/Interleaver.cpp \
src/Log.h \
@@ -109,15 +109,8 @@ odr_dabmux_SOURCES =src/DabMux.cpp \
src/MuxElements.cpp \
src/MuxElements.h \
src/PcDebug.h \
- src/ReedSolomon.h \
- src/ReedSolomon.cpp \
src/RemoteControl.cpp \
src/RemoteControl.h \
- src/TcpSocket.h \
- src/TcpSocket.cpp \
- src/UdpSocket.h \
- src/UdpSocket.cpp \
- src/ThreadsafeQueue.h \
src/crc.h \
src/crc.c \
src/fig/FIG.h \
@@ -167,6 +160,19 @@ odr_dabmux_SOURCES =src/DabMux.cpp \
src/PrbsGenerator.h \
src/utils.cpp \
src/utils.h \
+ lib/edi/STIDecoder.cpp \
+ lib/edi/STIDecoder.h \
+ lib/edi/STIWriter.cpp \
+ lib/edi/STIWriter.h \
+ lib/edi/PFT.cpp \
+ lib/edi/PFT.h \
+ lib/edi/common.cpp \
+ lib/edi/common.h \
+ lib/ReedSolomon.h \
+ lib/ReedSolomon.cpp \
+ lib/Socket.h \
+ lib/Socket.cpp \
+ lib/ThreadsafeQueue.h \
lib/zmq.hpp \
$(lib_fec_sources) \
$(lib_charset_sources)
@@ -205,18 +211,15 @@ odr_zmq2edi_SOURCES = src/zmq2edi/zmq2edi.cpp \
src/dabOutput/edi/TagPacket.h \
src/dabOutput/edi/Transport.cpp \
src/dabOutput/edi/Transport.h \
- src/InetAddress.h \
- src/InetAddress.cpp \
- src/TcpSocket.h \
- src/TcpSocket.cpp \
- src/UdpSocket.h \
- src/UdpSocket.cpp \
- src/ReedSolomon.h \
- src/ReedSolomon.cpp \
src/Log.h \
src/Log.cpp \
src/crc.h \
src/crc.c \
+ lib/ReedSolomon.h \
+ lib/ReedSolomon.cpp \
+ lib/Socket.h \
+ lib/Socket.cpp \
+ lib/ThreadsafeQueue.h \
lib/zmq.hpp \
$(lib_fec_sources)