summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2018-02-09 10:06:34 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2018-02-09 10:06:34 +0100
commitd10839ab23b4ac4dea5ba183c451b650dd07331a (patch)
tree5f78e10a89134a2a167315a42bc21c5cc3a3cdbb /src/Makefile.am
parentd1b74c21d8c6f816179cd700dd5859f51bf01d88 (diff)
downloaddabmux-d10839ab23b4ac4dea5ba183c451b650dd07331a.tar.gz
dabmux-d10839ab23b4ac4dea5ba183c451b650dd07331a.tar.bz2
dabmux-d10839ab23b4ac4dea5ba183c451b650dd07331a.zip
Move external code to lib and stop using SUBDIRS
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am152
1 files changed, 0 insertions, 152 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 1087588..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright (C) 2008, 2009,2012 Her Majesty the Queen in Right of Canada
-# (Communications Research Center Canada)
-# Pascal Charest
-#
-# Copyright (C) 2017, Matthias P. Braendli, http://opendigitalradio.org
-#
-
-# This file is part of ODR-DabMux.
-#
-# ODR-DabMux is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as
-# published by the Free Software Foundation, either version 3 of the
-# License, or (at your option) any later version.
-#
-# ODR-DabMux is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with ODR-DabMux. If not, see <http://www.gnu.org/licenses/>.
-
-if IS_GIT_REPO
-GITVERSION_FLAGS = -DGITVERSION="\"`git describe --dirty`\""
-else
-GITVERSION_FLAGS =
-endif
-
-bin_PROGRAMS=odr-dabmux zmqinput-keygen
-
-if HAVE_OUTPUT_RAW_TEST
-bin_PROGRAMS+=odr-zmq2farsync
-endif
-
-if HAVE_EDI_TEST
-bin_PROGRAMS+=odr-zmq2edi
-CURL_LIBS =-lcurl
-else
-CURL_LIBS =
-endif
-
-odr_dabmux_CFLAGS =-Wall -I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
-odr_dabmux_CXXFLAGS =-Wall -std=c++11 -I$(FARSYNC_DIR) $(GITVERSION_FLAGS) $(BOOST_CPPFLAGS) $(ZMQ_CPPFLAGS)
-odr_dabmux_LDADD =$(ZMQ_LIBS) $(CURL_LIBS) $(BOOST_LDFLAGS) \
- -lpthread $(BOOST_SYSTEM_LIB) $(BOOST_THREAD_LIB) $(BOOST_ASIO_LIB)
-
-odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
- DabMultiplexer.cpp DabMultiplexer.h \
- input/inputs.h \
- input/Prbs.cpp input/Prbs.h \
- input/Zmq.cpp input/Zmq.h \
- input/File.cpp input/File.h \
- input/Udp.cpp input/Udp.h \
- dabOutput/dabOutput.h \
- dabOutput/dabOutputFile.cpp \
- dabOutput/dabOutputFifo.cpp \
- dabOutput/dabOutputRaw.cpp \
- dabOutput/dabOutputSimul.cpp \
- dabOutput/dabOutputTcp.cpp \
- dabOutput/dabOutputUdp.cpp \
- dabOutput/dabOutputZMQ.cpp \
- dabOutput/metadata.h dabOutput/metadata.cpp \
- dabOutput/edi/AFPacket.cpp dabOutput/edi/AFPacket.h \
- dabOutput/edi/TagItems.cpp dabOutput/edi/TagItems.h \
- dabOutput/edi/TagPacket.cpp dabOutput/edi/TagPacket.h \
- dabOutput/edi/PFT.cpp dabOutput/edi/PFT.h \
- dabOutput/edi/Interleaver.cpp dabOutput/edi/Interleaver.h \
- ClockTAI.h ClockTAI.cpp \
- ConfigParser.cpp ConfigParser.h \
- Eti.h Eti.cpp \
- InetAddress.h InetAddress.cpp \
- Interleaver.h Interleaver.cpp \
- Log.h Log.cpp \
- ManagementServer.h ManagementServer.cpp \
- MuxElements.cpp MuxElements.h \
- PcDebug.h \
- ReedSolomon.h ReedSolomon.cpp \
- RemoteControl.cpp RemoteControl.h \
- TcpSocket.h TcpSocket.cpp \
- UdpSocket.h UdpSocket.cpp \
- ThreadsafeQueue.h \
- crc.h crc.c \
- fig/FIG.h fig/FIG.cpp \
- fig/FIG0.h fig/FIG0structs.h \
- fig/FIG0_0.cpp fig/FIG0_0.h \
- fig/FIG0_1.cpp fig/FIG0_1.h \
- fig/FIG0_2.cpp fig/FIG0_2.h \
- fig/FIG0_3.cpp fig/FIG0_3.h \
- fig/FIG0_5.cpp fig/FIG0_5.h \
- fig/FIG0_6.cpp fig/FIG0_6.h \
- fig/FIG0_8.cpp fig/FIG0_8.h \
- fig/FIG0_9.cpp fig/FIG0_9.h \
- fig/FIG0_10.cpp fig/FIG0_10.h \
- fig/FIG0_13.cpp fig/FIG0_13.h \
- fig/FIG0_17.cpp fig/FIG0_17.h \
- fig/FIG0_18.cpp fig/FIG0_18.h \
- fig/FIG0_19.cpp fig/FIG0_19.h \
- fig/FIG0_21.cpp fig/FIG0_21.h \
- fig/FIG0_24.cpp fig/FIG0_24.h \
- fig/FIG1.cpp fig/FIG1.h \
- fig/FIGCarousel.cpp fig/FIGCarousel.h \
- fig/TransitionHandler.h \
- mpeg.h mpeg.c \
- PrbsGenerator.cpp PrbsGenerator.h \
- utils.cpp utils.h \
- zmq.hpp \
- fec/char.h fec/rs-common.h \
- fec/decode_rs_char.c fec/decode_rs.h \
- fec/encode_rs_char.c fec/encode_rs.h \
- fec/fec.h \
- fec/init_rs_char.c fec/init_rs.h
-
-zmqinput_keygen_SOURCES = zmqinput-keygen.c
-zmqinput_keygen_LDADD = $(ZMQ_LIBS)
-zmqinput_keygen_CFLAGS = -Wall $(GITVERSION_FLAGS) $(ZMQ_CPPFLAGS)
-
-odr_zmq2farsync_SOURCES = zmq2farsync/zmq2farsync.cpp \
- dabOutput/dabOutput.h \
- dabOutput/dabOutputRaw.cpp \
- Log.h Log.cpp \
- zmq.hpp
-odr_zmq2farsync_LDADD = $(ZMQ_LIBS)
-odr_zmq2farsync_CFLAGS = -Wall $(ZMQ_CPPFLAGS) $(GITVERSION_FLAGS) -I$(FARSYNC_DIR)
-odr_zmq2farsync_CXXFLAGS = -Wall -std=c++11 $(ZMQ_CPPFLAGS) $(GITVERSION_FLAGS) -I$(FARSYNC_DIR)
-
-odr_zmq2edi_SOURCES = zmq2edi/zmq2edi.cpp \
- zmq2edi/EDISender.h zmq2edi/EDISender.cpp \
- dabOutput/dabOutput.h \
- dabOutput/metadata.h dabOutput/metadata.cpp \
- dabOutput/edi/AFPacket.cpp dabOutput/edi/AFPacket.h \
- dabOutput/edi/TagItems.cpp dabOutput/edi/TagItems.h \
- dabOutput/edi/TagPacket.cpp dabOutput/edi/TagPacket.h \
- dabOutput/edi/PFT.cpp dabOutput/edi/PFT.h \
- dabOutput/edi/Interleaver.cpp dabOutput/edi/Interleaver.h \
- InetAddress.h InetAddress.cpp \
- UdpSocket.h UdpSocket.cpp \
- ReedSolomon.h ReedSolomon.cpp \
- fec/char.h fec/rs-common.h \
- fec/decode_rs_char.c fec/decode_rs.h \
- fec/encode_rs_char.c fec/encode_rs.h \
- fec/fec.h \
- fec/init_rs_char.c fec/init_rs.h \
- Log.h Log.cpp \
- crc.h crc.c \
- zmq.hpp
-odr_zmq2edi_LDADD = $(ZMQ_LIBS) \
- -lpthread $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB)
-odr_zmq2edi_CFLAGS = -Wall $(ZMQ_CPPFLAGS) $(GITVERSION_FLAGS)
-odr_zmq2edi_CXXFLAGS = -Wall -std=c++11 $(ZMQ_CPPFLAGS) $(GITVERSION_FLAGS)
-
-EXTRA_DIST = fec/README.md \
- fec/LICENSE