summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-10-29 22:09:31 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-10-29 22:09:31 +0200
commit5132756f09c7a0dafe4644db92718ee3d1a58d6c (patch)
tree094343cedcd9fe8bacb3380e98d96e952b7115ea /src/Makefile.am
parent5c3c6d734ff0c57fd3d45746df23b96e0e7fc99e (diff)
parente7ad2e1fab9c51189fdc8b4f2d81f625da9dd422 (diff)
downloaddabmux-5132756f09c7a0dafe4644db92718ee3d1a58d6c.tar.gz
dabmux-5132756f09c7a0dafe4644db92718ee3d1a58d6c.tar.bz2
dabmux-5132756f09c7a0dafe4644db92718ee3d1a58d6c.zip
Merge branch 'next' into servicelinking
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5edd0a4..1d33231 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,7 @@
# (Communications Research Center Canada)
# Pascal Charest
#
-# Copyright (C) 2014, Matthias P. Braendli, http://mpb.li
+# Copyright (C) 2016, Matthias P. Braendli, http://opendigitalradio.org
#
# This file is part of ODR-DabMux.
@@ -41,7 +41,7 @@ CURL_LIBS =
endif
odr_dabmux_CFLAGS =-Wall -I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
-odr_dabmux_CXXFLAGS =-Wall -I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
+odr_dabmux_CXXFLAGS =-Wall -std=c++11 -I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
odr_dabmux_LDADD =$(ZMQ_LIBS) $(CURL_LIBS) \
-lpthread -lboost_thread -lboost_system -lboost_regex
@@ -87,7 +87,6 @@ odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
Log.h Log.cpp \
ManagementServer.h ManagementServer.cpp \
MuxElements.cpp MuxElements.h \
- ParserCmdline.cpp ParserCmdline.h \
PcDebug.h \
ReedSolomon.h ReedSolomon.cpp \
RemoteControl.cpp RemoteControl.h \
@@ -115,7 +114,7 @@ odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
fig/FIGCarousel.cpp fig/FIGCarousel.h \
fig/TransitionHandler.h \
mpeg.h mpeg.c \
- prbs.h prbs.c \
+ prbs.h prbs.cpp \
utils.cpp utils.h \
zmq.hpp \
fec/char.h fec/rs-common.h \
@@ -135,4 +134,4 @@ odr_zmq2farsync_SOURCES = zmq2farsync/zmq2farsync.cpp \
zmq.hpp
odr_zmq2farsync_LDADD = $(ZMQ_LIBS)
odr_zmq2farsync_CFLAGS = -Wall $(GITVERSION_FLAGS) -I$(FARSYNC_DIR)
-odr_zmq2farsync_CXXFLAGS = -Wall $(GITVERSION_FLAGS) -I$(FARSYNC_DIR)
+odr_zmq2farsync_CXXFLAGS = -Wall -std=c++11 $(GITVERSION_FLAGS) -I$(FARSYNC_DIR)