summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2015-04-23 09:10:35 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2015-04-23 09:10:35 +0200
commit606e22abcf8b9f3c3d63ccc8ccf8ae4020c6ffd3 (patch)
treee067c99ea946ba4877e12e3939c7fe6433d94f6f /src/Makefile.am
parent262a43fc5dcc04731a8951ee44555f582f7e8106 (diff)
downloaddabmux-606e22abcf8b9f3c3d63ccc8ccf8ae4020c6ffd3.tar.gz
dabmux-606e22abcf8b9f3c3d63ccc8ccf8ae4020c6ffd3.tar.bz2
dabmux-606e22abcf8b9f3c3d63ccc8ccf8ae4020c6ffd3.zip
Enable and take care of some warnings
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f3bce5e..6ed0921 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,7 @@
# along with ODR-DabMux. If not, see <http://www.gnu.org/licenses/>.
if IS_GIT_REPO
-GITVERSION_FLAGS = -DGITVERSION="\"`git describe`\""
+GITVERSION_FLAGS = -DGITVERSION="\"`git describe --dirty`\""
else
GITVERSION_FLAGS =
endif
@@ -39,7 +39,15 @@ bin_PROGRAMS=odr-dabmux odr-bridgetest
ZMQ_LIBS =
endif
-odr_dabmux_CPPFLAGS =-Wall -I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
+
+odr_dabmux_CPPFLAGS =-I$(FARSYNC_DIR) $(GITVERSION_FLAGS) \
+ -Wall -Wextra -Wno-unused-parameter \
+ -Wswitch-enum \
+ -Wdisabled-optimization -Wvla \
+ -Wuninitialized \
+ -Wc++11-compat \
+ -Wcast-align -Wcast-qual
+
odr_dabmux_LDADD =$(FEC_LIBS) $(ZMQ_LIBS) -lpthread -lboost_thread -lboost_system
odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
dabInput.h dabInput.cpp \