summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-11 22:15:35 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-11 22:24:33 +0200
commit9248c1d7976ba1c37e3df147a1eb3115fe72c8d0 (patch)
treee331a2fc4600fe80ca4e2b404d4379989a95d127 /src/Makefile.am
parent8750493994d574001e466fef21ded86730359640 (diff)
downloaddabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.tar.gz
dabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.tar.bz2
dabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.zip
Drop SLIP, Refactor sockets, improve TCP output
Quite a large refactoring of the sockets, TCP and UDP, in order to improve the ETI-over-TCP output. This can now accept several simultaneous connections, and requires a throttle. The SLIP input is gone. The UDP inputs are currently broken.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c572ef3..ede6649 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -65,7 +65,6 @@ odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
dabInputPrbs.h dabInputPrbs.cpp \
dabInputRawFile.h dabInputRawFile.cpp \
dabInputRawFifo.h dabInputRawFifo.cpp \
- dabInputSlip.h dabInputSlip.cpp \
dabInputTest.h dabInputTest.cpp \
dabInputUdp.h dabInputUdp.cpp \
dabInputZmq.h dabInputZmq.cpp \
@@ -94,7 +93,6 @@ odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
PcDebug.h \
ReedSolomon.h ReedSolomon.cpp \
RemoteControl.cpp RemoteControl.h \
- TcpServer.h TcpServer.cpp \
TcpSocket.h TcpSocket.cpp \
UdpSocket.h UdpSocket.cpp \
bridge.h bridge.c \