summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-02-07 08:50:39 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-02-07 09:01:02 +0100
commit8a93130b066efd90f5b7d775cb1b5812e7677863 (patch)
treea7bcf6c5c94ec9da89b684cf19e4126ffddf5001 /src/Makefile.am
parent2356d1f77f4a2a3dd75638621d687dc9d3771d6c (diff)
downloaddabmux-8a93130b066efd90f5b7d775cb1b5812e7677863.tar.gz
dabmux-8a93130b066efd90f5b7d775cb1b5812e7677863.tar.bz2
dabmux-8a93130b066efd90f5b7d775cb1b5812e7677863.zip
repair versioning and tarball generationv0.4.0
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c5b40d4..0097b2c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,9 +23,9 @@
bin_PROGRAMS=odr-dabmux odr-bridgetest
if IS_GIT_REPO
-GITVERSION_FLAGS = -DGITVERSION="\"-`git describe --long --tags`\""
+GITVERSION_FLAGS = -DGITVERSION="\"`git describe`\""
else
-GITVERSION_FLAGS = -DGITVERSION="\"-exported\""
+GITVERSION_FLAGS =
endif
FEC_FLAGS =
@@ -39,7 +39,7 @@ endif
odr_dabmux_CPPFLAGS =-I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
odr_dabmux_LDADD =$(FEC_LIBS) $(ZMQ_LIBS) -lpthread -lboost_thread -lboost_system
-odr_dabmux_SOURCES =DabMux.cpp \
+odr_dabmux_SOURCES =DabMux.cpp DabMux.h \
dabInput.h dabInput.cpp \
dabInputBridgeUdp.h dabInputBridgeUdp.cpp \
dabInputDabplusFifo.h dabInputDabplusFifo.cpp \