summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-01-17 18:42:32 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-01-17 18:42:32 +0100
commite8d55df0c08992521b303b689338c48ddfa307ce (patch)
treeb78229c8f040aca3b4bf85ba2ea0b83e524437d7 /src/Makefile.am
parentedb874717f758475d8fa1b433b71b601d1774e84 (diff)
downloaddabmux-e8d55df0c08992521b303b689338c48ddfa307ce.tar.gz
dabmux-e8d55df0c08992521b303b689338c48ddfa307ce.tar.bz2
dabmux-e8d55df0c08992521b303b689338c48ddfa307ce.zip
Make inputZMQ use the statistics, add munin script
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6dea558..910d5bc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -38,7 +38,7 @@ ZMQ_LIBS =
endif
crc_dabmux_CPPFLAGS =-I$(FARSYNC_DIR) $(GITVERSION_FLAGS)
-crc_dabmux_LDADD =$(FEC_LIBS) $(ZMQ_LIBS) -lpthread
+crc_dabmux_LDADD =$(FEC_LIBS) $(ZMQ_LIBS) -lpthread -lboost_thread -lboost_system
crc_dabmux_SOURCES =DabMux.cpp \
dabInput.h dabInput.cpp \
dabInputBridgeUdp.h dabInputBridgeUdp.cpp \
@@ -85,6 +85,7 @@ crc_dabmux_SOURCES =DabMux.cpp \
Interleaver.h Interleaver.cpp \
ReedSolomon.h ReedSolomon.cpp \
mpeg.h mpeg.c \
+ StatsServer.h StatsServer.cpp \
TcpServer.h TcpServer.cpp \
TcpSocket.h TcpSocket.cpp