summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli (think) <matthias@mpb.li>2012-08-23 20:20:30 +0200
committerMatthias P. Braendli (think) <matthias@mpb.li>2012-08-23 20:20:30 +0200
commit3b9073ec178d1ebd8563d94ebbb9b95726e31835 (patch)
tree895ed780d41501089e1464efd20482ab9a0e4c1c /src/Makefile.am
parent37f3f44cc1c0f5cf3a9b3f0ffc32f638b281994e (diff)
downloaddabmux-3b9073ec178d1ebd8563d94ebbb9b95726e31835.tar.gz
dabmux-3b9073ec178d1ebd8563d94ebbb9b95726e31835.tar.bz2
dabmux-3b9073ec178d1ebd8563d94ebbb9b95726e31835.zip
crc-dabmux: configuration file support for ensemble definitionr5
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 22 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 956e0f4..8a63e83 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,8 @@
-# Copyright (C) 2008, 2009 Her Majesty the Queen in Right of Canada
+# Copyright (C) 2008, 2009,2012 Her Majesty the Queen in Right of Canada
# (Communications Research Center Canada)
+#
+# Pascal Charest and
+# Matthias P. Braendli
# This file is part of CRC-DabMux.
#
@@ -16,7 +19,7 @@
# You should have received a copy of the GNU General Public License
# along with CRC-DabMux. If not, see <http://www.gnu.org/licenses/>.
-bin_PROGRAMS =CRC-DabMux CRC-BridgeTest
+bin_PROGRAMS=CRC-DabMux CRC-BridgeTest
FEC_FLAGS =
FEC_LIBS =-lfec
@@ -45,7 +48,10 @@ CRC_DabMux_SOURCES =DabMux.cpp \
dabInputUdp.h dabInputUdp.cpp \
dabOutput.h dabOutput.cpp \
bridge.h bridge.c \
- \
+ utils.cpp utils.h \
+ MuxElements.cpp MuxElements.h \
+ ParserCmdline.cpp ParserCmdline.h \
+ ParserConfigfile.cpp ParserConfigfile.h \
Eti.h Eti.cpp \
TcpLog.h TcpLog.cpp \
UdpSocket.h UdpSocket.cpp \
@@ -61,6 +67,17 @@ CRC_DabMux_SOURCES =DabMux.cpp \
TcpServer.h TcpServer.cpp \
TcpSocket.h TcpSocket.cpp
-CRC_BridgeTest_CFLAGS =-DBRIDGE_TEST
-CRC_BridgeTest_SOURCES =bridge.c \
+CRC_BridgeTest_CFLAGS =-DBRIDGE_TEST
+CRC_BridgeTest_SOURCES =bridge.c \
crc.c crc.h
+
+CRC-DabMux-cfg: CRC-DabMux
+ @echo "Copying CRC-DabMux to CRC-DabMux-cfg that reads ensemble config file"
+ cp CRC-DabMux CRC-DabMux-cfg
+
+.PHONY: CRC-DabMux-cfg
+
+all: CRC-DabMux-cfg all-am
+
+clean-local:
+ rm CRC-DabMux-cfg