summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-11 22:15:35 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-09-11 22:24:33 +0200
commit9248c1d7976ba1c37e3df147a1eb3115fe72c8d0 (patch)
treee331a2fc4600fe80ca4e2b404d4379989a95d127 /configure.ac
parent8750493994d574001e466fef21ded86730359640 (diff)
downloaddabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.tar.gz
dabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.tar.bz2
dabmux-9248c1d7976ba1c37e3df147a1eb3115fe72c8d0.zip
Drop SLIP, Refactor sockets, improve TCP output
Quite a large refactoring of the sockets, TCP and UDP, in order to improve the ETI-over-TCP output. This can now accept several simultaneous connections, and requires a throttle. The SLIP input is gone. The UDP inputs are currently broken.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 03c34d8..15b902c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,12 +131,6 @@ AC_ARG_ENABLE([input_test],
[], [enable_input_test=no])
AS_IF([test "x$enable_input_test" = "xyes"],
[AC_DEFINE(HAVE_INPUT_TEST, [1], [Define if TEST input is enabled])])
-# SLIP
-AC_ARG_ENABLE([input_slip],
- [AS_HELP_STRING([--enable-input-slip], [Enable SLIP input])],
- [], [enable_input_slip=no])
-AS_IF([test "x$enable_input_slip" = "xyes"],
- [AC_DEFINE(HAVE_INPUT_SLIP, [1], [Define if SLIP input is enabled])])
# UDP
AC_ARG_ENABLE([input_udp],
[AS_HELP_STRING([--enable-input-udp], [Enable UDP input])],
@@ -267,7 +261,7 @@ echo
echo "Inputs:"
enabled=""
disabled=""
-for output in prbs test slip udp fifo file
+for output in prbs test udp fifo file
do
eval var=\$enable_input_$output
AS_IF([test "x$var" = "xyes"],