summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli (think) <matthias@mpb.li>2012-08-26 21:41:41 +0200
committerMatthias P. Braendli (think) <matthias@mpb.li>2012-08-26 21:41:41 +0200
commit413f7559ad7fec7dd177b02862c559be95487c2d (patch)
treecd3cd4ad8507b2f44bac26acfb338287bd718f0a /configure.ac
parent6746613278df22e83f6147d1fc1d48300fcdce08 (diff)
downloaddabmux-413f7559ad7fec7dd177b02862c559be95487c2d.tar.gz
dabmux-413f7559ad7fec7dd177b02862c559be95487c2d.tar.bz2
dabmux-413f7559ad7fec7dd177b02862c559be95487c2d.zip
crc-dabmux: autoconf added boost version check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 89e0925..c6fdcfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,8 @@ AC_CONFIG_SRCDIR([src/DabMux.cpp])
AC_CONFIG_HEADER([config.h])
AM_SILENT_RULES([yes])
+AC_CONFIG_MACRO_DIR([m4])
+
case $host in
*linux*)
case $target_cpu in
@@ -51,11 +53,11 @@ AM_PROG_CC_C_O
AC_PROG_INSTALL
# Checks for libraries.
-# FIXME: Replace `main' with a function in `-lfec':
+
#AC_CHECK_LIB([fec], [init_rs_char], [], AC_MSG_ERROR([libfec is required]))
-# FIXME: Replace `main' with a function in `-lpthread':
+
AC_CHECK_LIB([pthread], [pthread_create], [], AC_MSG_ERROR([libpthread is required]))
-AC_CHECK_LIB([boost_system], [main], [], [AC_MSG_ERROR([library boost_system is missing])])
+AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
# Checks for header files.
AC_MSG_CHECKING([for OS type])