summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2015-06-21 22:25:12 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2015-06-21 22:25:12 +0200
commit1f499d8aec2625ef812f69cae6831581a9726ee8 (patch)
tree6f45e58a75ae09d45820302730afc78d15cad6b0 /configure.ac
parent1328d62f9d3a2eb9f089d531614302005c29ec37 (diff)
downloaddabmux-1f499d8aec2625ef812f69cae6831581a9726ee8.tar.gz
dabmux-1f499d8aec2625ef812f69cae6831581a9726ee8.tar.bz2
dabmux-1f499d8aec2625ef812f69cae6831581a9726ee8.zip
Add correct C++11 autotools check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e420cd..d4cf923 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,8 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_INSTALL
+AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
+
# Checks for libraries.
AC_CHECK_LIB([pthread], [pthread_create], [], AC_MSG_ERROR([libpthread is required]))
AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))