summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2013-12-15 15:56:32 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2013-12-15 16:32:15 +0100
commitf172d049863a38f33e8b15a3e47d4904b2c81323 (patch)
tree3c4fa6fba8002a1b5d9ce2edbd9720ba13d8417f /configure.ac
parent2b52846562d310d55a5e16149523e2aa7de2ab0a (diff)
downloaddabmux-f172d049863a38f33e8b15a3e47d4904b2c81323.tar.gz
dabmux-f172d049863a38f33e8b15a3e47d4904b2c81323.tar.bz2
dabmux-f172d049863a38f33e8b15a3e47d4904b2c81323.zip
Add ZeroMQ dabplus input
For use in combination with fdk-aac-dabplus-zmq
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f1f685f..c552337 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,15 @@ AC_ARG_ENABLE([input_file],
AS_IF([test "x$enable_input_file" = "xyes"],
[AC_DEFINE(HAVE_INPUT_FILE, [1], [Define if FILE input is enabled])])
+# ZeroMQ
+AC_ARG_ENABLE([input_zeromq],
+ [AS_HELP_STRING([--enable-input-zeromq], [Enable ZeroMQ input for dabplus])],
+ [], [enable_input_zeromq=no])
+AS_IF([test "x$enable_input_zeromq" = "xyes"],
+ [AC_CHECK_LIB(zmq, zmq_init, [] , AC_MSG_ERROR(ZeroMQ libzmq is required))])
+AS_IF([test "x$enable_input_zeromq" = "xyes"],
+ AC_DEFINE(HAVE_INPUT_ZEROMQ, [1], [Define if ZEROMQ input is enabled]))
+
# Outputs
# FILE
AC_ARG_ENABLE([output_file],
@@ -172,13 +181,17 @@ AC_ARG_ENABLE([output_simul],
[], [enable_output_simul=yes])
AS_IF([test "x$enable_output_simul" = "xyes"],
[AC_DEFINE(HAVE_OUTPUT_SIMUL, [1], [Define if SIMUL output is enabled])])
-# ZeroMQ message queue
+# ZeroMQ message queue output
AC_ARG_ENABLE([output_zeromq],
AS_HELP_STRING([--enable-output-zeromq], [Enable ZeroMQ output]))
AS_IF([test "x$enable_output_zeromq" = "xyes"],
- [AC_DEFINE(HAVE_OUTPUT_ZEROMQ, [1], [Define if ZeroMQ output is enabled]) ,
- AC_CHECK_LIB(zmq, zmq_init, ,[AC_MSG_ERROR([ZeroMQ libzmq is required])])])
-AM_CONDITIONAL([HAVE_OUTPUT_ZEROMQ_TEST], [test "x$enable_output_zeromq" = "xyes"])
+ AC_CHECK_LIB(zmq, zmq_init, [], [AC_MSG_ERROR([ZeroMQ libzmq is required])]))
+AS_IF([test "x$enable_output_zeromq" = "xyes"],
+ AC_DEFINE(HAVE_OUTPUT_ZEROMQ, [1], [Define if ZeroMQ output is enabled]))
+
+# Link against lzmq
+AM_CONDITIONAL([HAVE_ZEROMQ_TEST],
+ [test "x$enable_output_zeromq" = "xyes" -o "x$enable_input_zeromq" = "xyes"])
# Formats
@@ -240,7 +253,7 @@ echo
echo "Inputs:"
enabled=""
disabled=""
-for output in prbs test slip udp fifo file
+for output in prbs test slip udp fifo file zeromq
do
eval var=\$enable_input_$output
AS_IF([test "x$var" = "xyes"],