aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdbc05c..b71fb2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,10 @@ AS_IF([test "x$enable_fftw" = "xno"],
AS_IF([test "x$enable_fftw" = "xyes"],
[AC_DEFINE(USE_FFTW, [1], [Define to enable FFTW])])
+AS_IF([test "x$enable_fftw" = "xno"],
+ AC_MSG_ERROR([KISS FFT is currently broken. Please use FFTW. Any debugging help is appreciated]) )
+
+
AX_PTHREAD([], AC_MSG_ERROR([requires pthread]))
AC_SUBST([CFLAGS], ["$EXTRA $FFTW_CFLAGS $PTHREAD_CFLAGS"])