aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3f21f89..821ba1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,10 +19,11 @@
# along with ODR-DabMod. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.59)
-AC_INIT([ODR-DabMod], [0.5.1], [matthias.braendli@mpb.li])
+AC_INIT([ODR-DabMod], [0.5.2], [matthias.braendli@mpb.li])
AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_SYSTEM
-AM_INIT_AUTOMAKE([-Wall foreign])
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects])
AC_CONFIG_SRCDIR([src/DabMod.cpp])
AM_CONFIG_HEADER([config.h])
AM_SILENT_RULES([yes])
@@ -76,7 +77,7 @@ AC_ARG_ENABLE([zeromq],
# UHD support control
AC_ARG_ENABLE([output_uhd],
- [AS_HELP_STRING([--enable-output-uhd], [Enable UHD output])],
+ [AS_HELP_STRING([--disable-output-uhd], [Disable UHD output])],
[], [enable_output_uhd=yes])
AS_IF([test "x$enable_kiss" = "xno"],
@@ -186,9 +187,7 @@ AM_CONDITIONAL([HAVE_SSE], [test "x$has_sse" = "xyes"])
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([bzero floor ftime gettimeofday memset sqrt strchr strerror strtol])
-AC_CONFIG_FILES([Makefile
- lib/Makefile
- src/Makefile])
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT
echo