aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli (think) <matthias@mpb.li>2012-08-26 21:47:22 +0200
committerMatthias P. Braendli (think) <matthias@mpb.li>2012-08-26 21:47:22 +0200
commitc84de18fa8448c76426c60257c7ae8dac72a4039 (patch)
treeff1cfea971ada88867e411cf8abc1a99a88eb32d /configure.ac
parent4f3f33c245e3d92692eec0307d6f842c225a0a80 (diff)
downloaddabmod-c84de18fa8448c76426c60257c7ae8dac72a4039.tar.gz
dabmod-c84de18fa8448c76426c60257c7ae8dac72a4039.tar.bz2
dabmod-c84de18fa8448c76426c60257c7ae8dac72a4039.zip
crc-dabmod: autoconf added boost version check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8a427a..0fda4d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,8 @@ AM_INIT_AUTOMAKE([-Wall])
AC_CONFIG_SRCDIR([src/DabMod.cpp])
AM_CONFIG_HEADER([config.h])
+ACLOCAL_AMFLAGS = -I m4
+
case $target_cpu in
x86_64)
AC_DEFINE([__64BIT__], [], [__16BIT__, __32BIT__])
@@ -72,6 +74,8 @@ AC_SUBST([CFLAGS], ["$OPTIM $DEBUG $EXTRA"])
AC_SUBST([CXXFLAGS], ["$OPTIM $DEBUG $EXTRA"])
AC_CHECK_LIB([uhd], [main], [], [AC_MSG_ERROR([library uhd is missing])])
+
+AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
AC_CHECK_LIB([boost_system], [main], [], [AC_MSG_ERROR([library boost_system is missing])])
AC_CHECK_LIB([boost_thread], [main], [], [AC_MSG_ERROR([library boost_thread is missing])])