aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2018-08-06 10:35:22 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2018-08-06 10:35:22 +0200
commite95946831f8ef53d29590735a2df661385edb008 (patch)
treee179b6beed4a5a0dd108f078a529ae9f8107ed8e /configure.ac
parent8bc01ff60629d9096f4b57cfb574ace672a6ef0e (diff)
downloaddabmod-e95946831f8ef53d29590735a2df661385edb008.tar.gz
dabmod-e95946831f8ef53d29590735a2df661385edb008.tar.bz2
dabmod-e95946831f8ef53d29590735a2df661385edb008.zip
Replace boost by the standalone asio library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 30324a0..ea1cbb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,7 +115,7 @@ AS_IF([test "x$enable_easydabv3" = "xyes" && test "x$enable_output_uhd" == "xyes
# Checks for UHD.
AS_IF([test "x$enable_output_uhd" = "xyes"],
- [ AC_CHECK_LIB([uhd], [main], [], [AC_MSG_ERROR([library uhd is missing])])
+ [ PKG_CHECK_MODULES([UHD], [uhd], [], [AC_MSG_ERROR([UHD is required])])
])
AS_IF([test "x$enable_output_uhd" = "xyes"],
@@ -129,13 +129,6 @@ AS_IF([test "x$enable_edi" = "xyes"],
AM_CONDITIONAL([COMPILE_EDI], [test "x$enable_edi" = "xyes"])
-AS_IF([test "x$enable_easydabv3" = "xno"],
- [ AX_BOOST_BASE([1.54.0], [], AC_MSG_ERROR([BOOST 1.54 or later is required]))
- AX_BOOST_SYSTEM
- AX_BOOST_ASIO ])
-
-AS_IF([test "x$enable_easydabv3" = "xno"],
- AC_DEFINE(HAVE_BOOST, [1], [Define if boost is available]))
AS_IF([test "x$enable_easydabv3" = "xyes"],
AC_DEFINE(BUILD_FOR_EASYDABV3, [1], [Define if we are building for EasyDABv3]))