summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 878ed5d..50a6e70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,9 +58,12 @@ if pkg-config MagickWand; then
AC_SUBST(MAGICKWAND_CFLAGS)
AC_SUBST(MAGICKWAND_LDADD)
else
- AC_MSG_ERROR(MagickWand not found)
+ AC_MSG_WARN(MagickWand not found)
fi
+AS_IF([ pkg-config MagickWand ],
+ AC_DEFINE(HAVE_MAGICKWAND, [1], [Define if MagickWand is available]))
+
dnl soname version to use
dnl goes by ‘current[:revision[:age]]’ with the soname ending up as