summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3796ab0..2924d19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,12 @@ LT_INIT
AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
# std::thread requires pthread
-AX_PTHREAD([], AC_MSG_ERROR([requires pthread]))
+AX_PTHREAD( [
+ AC_DEFINE(HAVE_PTHREAD,1,[Define if you have POSIX threads libraries and header files.])
+ CLIBS="$PTHREAD_LIBS $LIBS"
+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ LDFLAGS="$LDFLAGS $PTHREAD_CFLAGS"
+ CC="$PTHREAD_CC"], [AC_MSG_ERROR([requires pthread])] )
AC_CHECK_LIB([m], [sin])