summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 12 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 39704d6..b4ad1e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,21 +1,12 @@
dnl -*- Autoconf -*-
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([fdk-aac], [0.1.3], [http://sourceforge.net/projects/opencore-amr/])
+AC_INIT([fdk-aac-dabplus], [0.1.0], [http://opendigitalradio.org/])
AC_CONFIG_AUX_DIR(.)
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([tar-ustar foreign])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-dnl Various options for configure
-AC_ARG_ENABLE([example],
- [AS_HELP_STRING([--enable-example],
- [enable example encoding program (default is no)])],
- [example=$enableval], [example=no])
-
-dnl Automake conditionals to set
-AM_CONDITIONAL(EXAMPLE, test x$example = xyes)
-
dnl Checks for programs.
AC_PROG_CC
AC_PROG_CXX
@@ -30,15 +21,18 @@ AC_CHECK_LIB([boost_thread], [main], [], [AC_MSG_ERROR([library boost_thread is
AC_CHECK_LIB([rt], [clock_gettime], [], [AC_MSG_ERROR([library rt is missing])])
-# fdk-aac-dabplus-zmq needs ZeroMQ
-AC_ARG_ENABLE([zmq],
- [AS_HELP_STRING([--enable-zmq], [Enable fdk-aac-dabplus-zmq with ZeroMQ output])]
- )
-AS_IF(test "x$enable_zmq" = "xyes",
- AC_CHECK_LIB(zmq, zmq_init, , AC_MSG_ERROR(ZeroMQ libzmq is required)))
-
-AM_CONDITIONAL(HAVE_ZEROMQ_TEST, test "x$enable_zmq" = "xyes")
+# fdk-aac-dabplus-zmq needs ZeroMQ
+AC_CHECK_LIB(zmq, zmq_init, , AC_MSG_ERROR(ZeroMQ libzmq is required))
+
+if pkg-config MagickWand; then
+ MAGICKWAND_CFLAGS=`pkg-config MagickWand --cflags`
+ MAGICKWAND_LDADD=`pkg-config MagickWand --libs`
+ AC_SUBST(MAGICKWAND_CPPFLAGS)
+ AC_SUBST(MAGICKWAND_LDADD)
+else
+ AC_MSG_ERROR(MagickWand not found)
+fi
dnl soname version to use
dnl goes by ‘current[:revision[:age]]’ with the soname ending up as