summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d8f54e..e1449d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,8 @@ endif
dabplus_enc_LDFLAGS = -no-install
dabplus_enc_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
- -lrt -lboost_thread $(dabplus_enc_LDADD_JACK)
+ -lrt -lboost_thread $(dabplus_enc_LDADD_JACK) \
+ $(LIBVLC_LIBS)
dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS) -ggdb
dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/FileInput.cpp \
@@ -61,6 +62,8 @@ dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/AlsaInput.h \
src/JackInput.cpp \
src/JackInput.h \
+ src/VLCInput.cpp \
+ src/VLCInput.h \
src/SampleQueue.h \
src/encryption.c \
src/encryption.h \