summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 30 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 459e61d..bf31fdd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,12 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = subdir-objects
+if IS_GIT_REPO
+GITVERSION_FLAGS = -DGITVERSION="\"`git describe`\""
+else
+GITVERSION_FLAGS =
+endif
+
AM_CPPFLAGS = \
-I$(top_srcdir)/libAACdec/include \
-I$(top_srcdir)/libAACenc/include \
@@ -37,27 +43,30 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
#aac_enc_SOURCES = src/aac-enc.c \
# src/wavreader.c
-dabplus_enc_file_LDADD = libfdk-aac.la -lfec
-dabplus_enc_file_SOURCES = src/dabplus-enc-file.c \
- src/wavreader.c
-
-dabplus_enc_file_zmq_LDADD = libfdk-aac.la -lfec -lzmq
-dabplus_enc_file_zmq_SOURCES = src/dabplus-enc-file-zmq.c \
- src/wavreader.c \
- contrib/lib_crc.h \
- contrib/lib_crc.c
-
-dabplus_enc_alsa_zmq_LDFLAGS = -no-install
-dabplus_enc_alsa_zmq_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
- -lrt -lboost_thread
-dabplus_enc_alsa_zmq_SOURCES = src/AlsaDabplus.cpp \
- src/AlsaInput.cpp \
- src/AlsaInput.h \
- src/SampleQueue.h \
- src/zmq.hpp
-
-
-mot_encoder_CFLAGS = @MAGICKWAND_CFLAGS@ -Icontrib
+dabplus_enc_file_LDADD = libfdk-aac.la -lfec
+dabplus_enc_file_CFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
+dabplus_enc_file_SOURCES = src/dabplus-enc-file.c \
+ src/wavreader.c
+
+dabplus_enc_file_zmq_LDADD = libfdk-aac.la -lfec -lzmq
+dabplus_enc_file_zmq_CFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
+dabplus_enc_file_zmq_SOURCES = src/dabplus-enc-file-zmq.c \
+ src/wavreader.c \
+ contrib/lib_crc.h \
+ contrib/lib_crc.c
+
+dabplus_enc_alsa_zmq_LDFLAGS = -no-install
+dabplus_enc_alsa_zmq_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
+ -lrt -lboost_thread
+dabplus_enc_alsa_zmq_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
+dabplus_enc_alsa_zmq_SOURCES = src/AlsaDabplus.cpp \
+ src/AlsaInput.cpp \
+ src/AlsaInput.h \
+ src/SampleQueue.h \
+ src/zmq.hpp
+
+
+mot_encoder_CFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib
mot_encoder_LDADD = @MAGICKWAND_LDADD@
mot_encoder_SOURCES = src/mot-encoder.c \
contrib/lib_crc.h \