summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2021-02-24 09:50:43 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2021-02-24 09:50:43 +0100
commit233db5d21b9257f611883ffddc66e5dd26878e66 (patch)
tree3283ab0522ed0fb48f5c3b6801941a6a0e1ddc34 /configure.ac
parent353e00a8027599124125a314a95ed7a735c30388 (diff)
downloadODR-AudioEnc-233db5d21b9257f611883ffddc66e5dd26878e66.tar.gz
ODR-AudioEnc-233db5d21b9257f611883ffddc66e5dd26878e66.tar.bz2
ODR-AudioEnc-233db5d21b9257f611883ffddc66e5dd26878e66.zip
Update autoconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0e59cf5..0ae417b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,16 +1,21 @@
dnl -*- Autoconf -*-
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([ODR-AudioEnc], [3.0.0], [http://opendigitalradio.org/])
-AC_CONFIG_AUX_DIR(.)
+AC_PREREQ([2.69])
+AC_INIT([ODR-AudioEnc],[3.0.0],[http://opendigitalradio.org/])
+AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE([tar-ustar foreign])
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-AC_CONFIG_HEADER([config.h])
+AC_CANONICAL_TARGET
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects])
+AM_SILENT_RULES([yes])
+AC_CONFIG_SRCDIR([src/odr-audioenc.cpp])
+AC_CONFIG_HEADERS([config.h])
dnl Checks for programs.
-AC_PROG_CC
AC_PROG_CXX
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_INSTALL
AC_PROG_RANLIB
AM_PROG_AR