summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2012-07-01 12:15:32 +0300
committerMartin Storsjo <martin@martin.st>2012-09-13 23:27:27 +0300
commitbf0d9ddc43b25f0fb56ed69ff72d1c37c29e2db6 (patch)
tree6000aac50369411458eb5b9ee9241cf4b7d04fb2 /configure.ac
parent923f3e95f3e332d26f03cf6782f0ab61596ceef2 (diff)
downloadODR-AudioEnc-bf0d9ddc43b25f0fb56ed69ff72d1c37c29e2db6.tar.gz
ODR-AudioEnc-bf0d9ddc43b25f0fb56ed69ff72d1c37c29e2db6.tar.bz2
ODR-AudioEnc-bf0d9ddc43b25f0fb56ed69ff72d1c37c29e2db6.zip
Add an encoder example
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cfa77ad..44fb2f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,17 @@ AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([tar-ustar foreign])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+dnl Various options for configure
+AC_ARG_ENABLE([example],
+ [AS_HELP_STRING([--enable-example],
+ [enable example encoding program (default is no)])],
+ [example=$enableval], [example=no])
+
+dnl Automake conditionals to set
+AM_CONDITIONAL(EXAMPLE, test x$example = xyes)
+
dnl Checks for programs.
+AC_PROG_CC
AC_PROG_CXX
LT_INIT