summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-03-07 10:46:36 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-03-07 10:46:36 +0100
commit7284422f3a907724af91de827b2d32220d0d4ba1 (patch)
treedda481445a21bce5f8fad471184e0131038840ef /configure.ac
parent8d26f0804a03a222ca7b791f40ec51dba3b8162d (diff)
downloadODR-AudioEnc-7284422f3a907724af91de827b2d32220d0d4ba1.tar.gz
ODR-AudioEnc-7284422f3a907724af91de827b2d32220d0d4ba1.tar.bz2
ODR-AudioEnc-7284422f3a907724af91de827b2d32220d0d4ba1.zip
alsa-dabplus compiles
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04252ce..39704d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,12 @@ LT_INIT
AC_CHECK_LIB([m], [sin])
+AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
+AC_CHECK_LIB([boost_system], [main], [], [AC_MSG_ERROR([library boost_system is missing])])
+AC_CHECK_LIB([boost_thread], [main], [], [AC_MSG_ERROR([library boost_thread is missing])])
+
+AC_CHECK_LIB([rt], [clock_gettime], [], [AC_MSG_ERROR([library rt is missing])])
+
# fdk-aac-dabplus-zmq needs ZeroMQ
AC_ARG_ENABLE([zmq],
[AS_HELP_STRING([--enable-zmq], [Enable fdk-aac-dabplus-zmq with ZeroMQ output])]